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수업 방향

조립체 모델

스케치

모델링

그 외 부품 모델링조립 후 구동확인

도면 자료
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실행 화면

CATIA 실행화면
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화면 구성

작업트리

주 메뉴

작업 화면

작업 도구 모음

컴파스

작업 워크벤치

일반 도구 모음
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화면 구성 : 모델이 있는 경우

작업트리

주 메뉴

작업 화면

작업 도구 모음

컴파스

작업 워크벤치

일반 도구 모음
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FILE 메뉴: 모델 불러오기

모델 파일 불러오기

(파일의 버전보다 사용 CATIA 버전이 낮을 경우 에러 발생)

메뉴에서 열기 실행 화면에 드래그 또는 파일 더블클릭

하단의 툴바 이용
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FILE 메뉴: 모델 저장하기

모델 파일 저장하기

파일 불러오는 것과 마찬가지로 메뉴의

File→Save를 통해 저장하거나 작업화면

하단의 저장버튼 또는 Ctrl+s 단축키를 이

용하여 저장할 수 있다. 

• 현재의 저장위치에 동일한 이름으로 저장
• 저장위치, 이름, 확장자를 변경하여 저장
• 열려있는 모든 파일을 동일한 속성으로 저장
• 열려있는 각각의 파일들의 저장방식 조절 가능
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사용 가능한 파일 종류

CATIA V5의 주요 File Format

File Format 설 명

*.CATPart Part Design의 모델링 데이터를 저장하는 file format

*.CATProduct Assembly Design의 데이터를 저장하는 file format

*.CATDrawing 도면 데이터를 저장하는 file format

*.CATAnalysis CAE 해석 데이터를 저장하는 file format

File Format 설 명

*.dxf, *.dwg Autocad 표준 format을 read/write 할 수 있다. 

*.igs,*.stp,*.step igs, step 등의 중립 format을 read/write 할 수 있다. 

기타 File Format
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마우스 조작

대상선택

화면이동
(휠)

확대/회전
(휠, 버튼 )

문맥적 기능
(Contextual 

Menu)

마우스 버튼을 이용하여 모델의 선택/이동/회전 등이 가능

회전 확대/축소
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COMPASS 사용하기

화면 오른쪽 상단의 Compass 조작법
- 마우스를 대신하여 화면 조작 가능 (드래그하여 파트에 부착할 경우 부착위치 기준으로 조작가능)
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START 메뉴

Solutions & Workbenches

Workbenches

Solutions

열려있는 작업

이전 작업

Quick start 
menu
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START 메뉴

수업에 사용될 주요 워크벤치

 Sketcher

- 설계를 위한 스케치

 Part Design

- 3D 부품 설계

 Assembly Design

- 설계된 부품들을 조립

 Drafting

- 2D 도면을 생성

 Generative Shape Design

- Wireframe, surface 를 이용하여 설계

 DMU Kinematics

- 조립된 모델의 구동 확인
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사용자 정의 (CUSTOMIZE) 

사용자정의(customize) 옵션
- 워크벤치 메뉴, 툴바, 단축키, 언어 등에 대한 설정 가능

• Tools → Customize
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사용자 정의 (CUSTOMIZE) 

Start menu
- 빠른 워크벤치 실행 가능

설정 후

시작화면
단축키 설정

설정 전
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사용자 정의 (CUSTOMIZE) 

Restore position : Toolbar 원위치

Toolbars
- 툴바의 생성 및 위치 조정

Commands

단축키 설정
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사용자 정의 (CUSTOMIZE) 

Options

TooltipsIcon Size Ratio = 2.8 
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옵션 (OPTIONS)

• Tool → Options

그 외 다양한 옵션 설정

색상
(Options → General → Display → Visualization)

단위
(Options → General → Parameters…→ Units)

그래픽 표현
(Options → General → Display → Performance)

스케치 옵션
(Options → Mechanical Design → Sketcher)
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VIEW (FIT ALL IN)

화면에 꽉 차게 보여줌

• View → Fit All In

화면 하단의 툴바 이용 가능
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화면 하단의 툴바 이용 가능

VIEW (NORMAL VIEW)

선택한 평면에 수직한 화면을 보여줌

• View → Modify → Normal View
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화면 하단의 툴바 이용 가능

VIEW (CREATE MULTI-VIEW)

모델의 여러 위치의 화면을 나누어 보여줌

• View → Navigation Mode → Multi-View Customization

원하는 배치 조정 가능
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VIEW (QUICK VIEW)

Isometric View Front View

Top View

Top, ISO, Side 등의 view로 형상을 배치시킬 때 사용

• View → Named Views

더블클릭 혹은 Apply버튼을 클릭하여 사용
(Add를 이용해 사용자가 원하는 화면위치 저장도 가능)

화면 하단의 툴바 이용 가능

Right View
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VIEW (VIEW MODE)

모델의 표현 방법 설정

• View → Render Style

화면 하단의 툴바 이용 가능

Shading Shading with Edges

Shading with Edges and Hidden Edges Wireframe
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VIEW (VIEW MODE)

모델에 적용한 재료를 표현

• View → Render Style → Shading with Material

재료입력 (재료특성 포함)
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VIEW (VIEW MODE)

모델의 표현 방법 설정 : 사용자 정의

• View → Render Style → Customize View
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VIEW (PARALLEL/PERSPECTIVE)

원근감을 고려한 화면 배치

Parallel Perspective

• View → Render Style → Perspective/Parallel  

 Perspective: 원근감을 고려한 사실적인 화면구성

 Parallel: 원근감을 고려하지 않은 모델링을 위한 화면 구성
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VIEW (GRAPHIC PROPERTIES)

Geometry의 색, 투명도 등을 조절

painter를 이용하면 다른 부분에 적용된 색상을 복사해서
적용 가능

Solid/Surface를 구성하는 면의 색상 설정

투명도 설정

Line/Curve 종류 설정

Line/Curve 두께 설정

Point 종류 설정

Painter

Layer 설정

• View → Toolbars → Graphic Properties
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WINDOW 메뉴

 New Window : 활성화된 작업을 복사하여 새로운 화면 생성

 Tile Horizontally : 현재 작업중인 파일을 수평 배열

 Tile Vertically : 현재 작업중인 파일을 수직 배열

 Cascade : 현재 작업중인 파일을 계단식 배열

메뉴의 Window 기능을 이용해 현재 CATIA 창에 열려있는 파일 분할 배치

Tile Horizontally Tile Vertically Cascade
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HIDE/SHOW

Hide/Show : 선택한 물체를 숨기거나 보여줌

트리에서 오른쪽 마우스 클릭

또는 화면 하단의 툴바 이용 가능

Part Design → Tools → Show/Hide

숨기고자 하는 대상에 마우스 오른쪽 버튼에서 클릭

Hide/Show

숨겨져 있는 모델 확인
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작업 트리의 흰색 가지 부분이나 오른쪽 하단의 x/y/z 축을 선택하게 되면
Geometry의 색이 어둡게 바뀌면서 작업 트리의 조정이 가능하게 된다. 

이럴 경우 다시 작업 트리의 흰색 가지나 오른쪽 하단의 x/y/z 축을 선택하
면 원 상태로 돌아가게 된다. 

트리 조정 중 작업 트리가 사라질 경우
- 마우스 오른쪽 클릭 -> Reframe graph
- 화면 하단 메뉴 중 클릭

작업 트리의 이동/확대/축소
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MEASURE

측정 아이콘을 통해 여러 치수 측정 가능

Measure Between Measure Item
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MEASURE

측정 아이콘을 통해 여러 치수 측정 가능

Measure Inertia

3D 2D
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HELP DOCUMENT

- Help Document 사용방법 1

메뉴를 통해 실행

아래의 물음표 버튼 클릭 후
궁금한 툴바 아이콘 클릭

간단한 설명과 함께
More info… 가 나타남

설치가 되어 있지 않을 경우

온라인으로 볼 수 있는 곳(R19)
- http://maruf.ca/files/catiahelp

설치가 되어 있을 경우

클릭 시 해당 도움말로 이동

- Help Document 사용방법 2 (설치가 되어 있을 경우)

CATIA의 Help Document 사용방법
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GRABCAD.COM

모델 관련 참고 사이트 (Community → Library)
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SKETCHER
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일반적인 스케치 순서

기준평면 선택 대략적인 스케치
주요부분 수정

Constraints를 이용
해 정확한 수치 결정

스케치 기반 모델 생성
스케치 수정최종 모델 완성
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SKETCHER 시작하기

Start 메뉴에서 Sketcher 선택 후 기준(작업) 평면 선택

작업 평면 선택

혹은, 화면 우측 툴바에서 Sketch 선택 후 작업 평면 선택
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SKETCHER 작업화면

작업트리

주 메뉴

작업 화면

작업 도구 모음

컴파스

일반 도구 모음

스케치에서
나가기
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SKETCHER 툴바 종류

Profile 툴바

Work Mode 툴바 Constraint 툴바

Operation 툴바
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Grid 
- 화면상에 Grid Line을 표시함.
(Tools→Options→Mechanical Design→Sketcher에서 간격 수정)

SKETCHER TOOLS

Sketcher Work Mode

Snap to Point 
- Grid point 에만 점이 찍히도록 함

Construction/Standard Element 
- 점선 형태의 보조선 생성

Construction Profile

Standard Profile
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SKETCHER TOOLS

Sketcher Work Mode

Geometrical Constraints
- Constraints/SmartPic에서 정의된 구속조건

자동 생성.

Dimensional Constraints 
- Sketcher Tool Bar에서 사용자가 입력한 값에

대한 치수 구속 적용 (tab 키 혹은 마우스 사용)

Construction Profile

Tools→Options→Mechanical
Design→Sketcher
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SKETCHER TOOLS

Sketcher Work Mode

User Selection Filter
- 해당 요소만 선택 가능하도록 해줌

Line 선택 시 Point 선택 시
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SKETCHER PROFILE

Profile

Three Point Arc : 3점을 지나는 원호를 생성

Tangent Arc : 이전 Line에 Tangent 한 원호를 생성

Line : 연속적인 직선을 생성

생성된 Profile 간의 구속을 사용하지 않을
경우 경우 Shift 키를 이용

<Shift 키 사용> <Shift 키 사용 x> 

Tangent Arc의 경우 툴바에서 클릭하거나
마우스 왼쪽 버튼을 이용하여 생성 가능

<마우스 왼쪽 버튼을 누른 채로 약간 움직이면 사용가능> 



CAD

Copyright ©  Computational Design Lab. All rights reserved.
50

SKETCHER PROFILE

Predefined Profile

21

2

1

3

Rectangle Oriented Rectangle

2
1

3

2
1

3

2

1

3 4

Parallelogram

Elongated Hole Cylindrical Elongated Hole
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SKETCHER PROFILE

Predefined Profile

2
1

2
1

Keyhole Profile Hexagon

2

1

3

Centered Rectangle Centered Parallelogram

<방향을 잡아줄 2개의 직선이 필요함>
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SKETCHER PROFILE

Circle

2

1

2
1

3

Circle Three Point Circle Circle Using Coordinates

Tri-Tangent Circle

<3개의 직선에 접하는 원>

Arc

2

13

1

2

3

Three Point /Arc Three Point Arc Starting with Limits

1 2

3
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SKETCHER PROFILE

Spline

Spline Connect

Tension 

3

1

Tension 

3

1

<Connect with an Arc><Continuity in tangency>

<Continuity in point><Continuity in curvature>
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SKETCHER PROFILE

Conic

Ellipse
- 장축과 단축으로 정의된 타원 생성.

2

1

3
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SKETCHER PROFILE

Conic

Parabola by Focus Hyperbola by Focus

2

1

3

4

2

1

3

45

Conic

2

1 3

4

5

21

3

4

2
1

3

4
5

2

1

3
4

5

21

3

4

5
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SKETCHER PROFILE

Conic

Conic

• If parameter = 0.5, parabola.

• If 0 < parameter < 0.5, arc of ellipse.

• If 0.5 < parameter < 1, hyperbola.

2

1
3

4

5

𝑃𝑎𝑟𝑎𝑚𝑒𝑡𝑒𝑟 =
𝑂𝑀

𝑂𝑇
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SKETCHER PROFILE

Line

Line Infinite Line

2

1

2

1

Bi-Tangent Line

Bisecting Line Line Normal To Curve /       Select a Curve before

2

1

2

1
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SKETCHER PROFILE

Axis

Point by Clicking

Point by Using Coordinates

Projection Point

회전체의 중심 축 역할을 한다.

(Construction element이기 때문에 3D

작업화면에서는 나타나지 않는다.)

Point

Equidistant Point

Intersection Point

Align Points
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실습 예제

Piston Connecting Rod

Connecting Rod
- 피스톤과 크랭크 축을 연결하는 부품으로 피스톤의 왕복운동을 크랭크 축의 회전운동으로 바꿔줌
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실습 예제

Piston Connecting Rod

Connecting Rod
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CONTENTS

 시작하기

 Profile 을 이용한 스케치

 Constraint 을 이용한 스케치

 Operation 을 이용한 스케치
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SKETCHER CONSTRAINT

Sketcher Constraint
- 구속조건을 부여하여 스케치가 정확한 값/위치를 갖도록 함

Under-Constraint (White)
- 구속이 부족한 상태

Fully-Constraint (Green)
- 완전 구속되어 움직이지 않음

Over-Constraint (Purple)
- 중복된 구속이 존재함

Inconsistent-Constraint (Red)
- 모순된 구속이 존재함

Tools → Options → Mechanical Design 
→ Sketcher



CAD

Copyright ©  Computational Design Lab. All rights reserved.
63

SKETCHER CONSTRAINT

Constraints Defined in Dialog Box

2

1

Sketcher Constraint

1 2

3

참고: Shift key를 클릭한 채로 스케치 작업을 수행할
경우 자동으로 구속이 생기는 것을 방지
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SKETCHER CONSTRAINT

Constraints Defined in Dialog Box

2

1

SketcherConstraint

1

2
3
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SKETCHER CONSTRAINT

Constraints
- 보다 편하게 구속 부여 가능.

Contact Constraints
- 접촉 구속조건(나중에 선택한 요소가 이동)

Sketcher Constraint

마우스 우클릭
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SKETCHER CONSTRAINT

Fix Together
- 여러 profile을 하나로 묶음.

Auto Constraints
- 선택한 요소 사이의 구속을 자동으로 부여

SketcherConstraint
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SKETCHER CONSTRAINT

Animate Constraints
- 변경시키고자 하는 구속 값 클릭

Edit-Multi Constraints
- 여러 구속조건을 한번에 편집가능.

SketcherConstraint
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실습 예제
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실습 과제 1

• 아래의 도면을 보고 스케치 해보기
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CONTENTS

 시작하기

 Profile 을 이용한 스케치

 Constraint 을 이용한 스케치

 Operation 을 이용한 스케치
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Construction Lines Trim

SKETCHER OPERATION

Corner/Chamfer

Corner ( Chamfer )

No Corner All Trim Element Trim First Element No Trim

Standard Lines Trim Construction Lines No Trim
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SKETCHER OPERATION

Relimitations

Trim
(Trim All Elements)

2

1

Trim
(Trim First Elements)

2

1

Break
- 선택한 라인을 분할
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SKETCHER OPERATION

Relimitations

Quick Trim
(Break And Rubber In)

No Trim

Quick Trim
(Break And Rubber Out)

No Trim

Quick Trim
(Break And Keep)
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SKETCHER OPERATION

Relimitations

Close arc: 원의 남은 부분을 생성 Complement: 원의 나머지 부분으로 변경
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SKETCHER OPERATION

Transformation

Mirror (대칭 복사) Symmetry (대칭 이동) Translate

Rotate
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SKETCHER OPERATION

Transformation

Scale
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SKETCHER OPERATION

Transformation

Offset : 설정한 값만큼 기존 스케치로부터 동일한 간격의 스케치 생성

Point Propagation

Tangent Propagation

No Propagation

No Propagation Tangent Propagation Point Propagation

Offset 개수

Both Side Offset
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SKETCHER OPERATION

Transformation

Both Side Offset Offset 개수가 2개 일 경우

Offset : 설정한 값만큼 기존 스케치로부터 동일한 간격의 스케치 생성

Point Propagation

Tangent Propagation

No Propagation Offset 개수

Both Side Offset
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SKETCHER OPERATION

3D Geometry

Project 3D Elements
- 3D 모델의 요소를 평면에 투영함

Intersect 3D Element
- 3D 모델과 평면이 교차하는 요소를 생성
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SKETCHER OPERATION

3D Geometry

Project 3D Canonical Silhouette Edges
- 회전체의 실루엣을 투영함(회전면)

Project 3D Silhouette Edges
- 회전체의 실루엣을 투영함
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SKETCHER OPERATION

Sketch Analysis
- 완성된 Sketch를 점검하는 기능

Tools → Sketch Analysis

또는 화면 하단의 툴바 이용
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실습 예제 1
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실습 예제 2

CATIA Mechanical Design 도면집, 김동주 외, 과학기술,  2009

Note
1. Transformation의 Rotation 기능 이용
2. 완전 구속 할 필요 없음
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실습 예제 3

Note
1. 표기하지 않은 R=3
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실습 과제 1

Note
1. 선 사이의 연결은 tangency constraint 이용

• 아래의 도면을 보고 스케치 해보기
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실습 과제 2

Note
1. 선 사이의 연결은 tangency constraint 이용
2. Cylindrical Elongated Hole 기능 이용

• 아래의 도면을 보고 스케치 해보기


